Actions keep loading.

Incident Report for Nmbrs

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 10:41 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2025 - 09:27 CET

Investigating

Tasks such as processing the run, payroll declaration and downloading the pay slips continue to load. This is a high priority in research.
Posted Feb 24, 2025 - 07:06 CET
This incident affected: Nmbrs Netherlands (Web Application (APM)).