Slowness in application
Incident Report for Nmbrs
Resolved
This incident has been resolved.
Posted May 03, 2021 - 13:39 CEST
Investigating
We are currently investigating this issue.
Posted May 03, 2021 - 11:53 CEST
This incident affected: Visma Nmbrs Netherlands (Web Application (APM), Sandbox, API).