Slowness in application
Incident Report for Nmbrs
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 08:53 CET
Investigating
We are currently investigating this issue.
Posted Mar 22, 2021 - 11:26 CET
This incident affected: Visma Nmbrs Netherlands (Web Application (APM), Sandbox) and Visma Nmbrs Sweden (Web Application (APM), Sandbox).