Slowness when navigating in environments

Incident Report for Nmbrs

Resolved

This incident has been resolved.
Posted Dec 16, 2019 - 11:43 CET

Monitoring

The situation has improved. We are monitoring the issue closely.
Posted Dec 16, 2019 - 10:26 CET

Investigating

We have received multiple mentions of slowness in environments. We are investigating the issue!
Posted Dec 16, 2019 - 10:16 CET
This incident affected: Nmbrs Netherlands (Web Application (APM)).