Scheduled Maintenance 06-08-2020
Scheduled for Aug 6, 20:00 - 22:00 CEST
Update
Tonight's update is cancelled (30/7/2020). We will be undergoing scheduled maintenance next week on the 6th of August.
Posted Jul 30, 2020 - 16:02 CEST
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Jul 24, 2020 - 11:36 CEST
This scheduled maintenance affects: Nmbrs® Sweden (Web Application (APM), Sandbox, API) and Nmbrs® Netherlands (Web Application (APM), Sandbox, API).