Degraded performance due to Microsoft outage

Incident Report for Nmbrs

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:16 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 22:52 CET

Update

Due to the microsoft outage we decided to put Nmbrs offline
Posted Oct 29, 2025 - 18:27 CET

Update

Microsoft has also published a status page regarding this issue, which can be found here: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 17:33 CET

Identified

Nmbrs is currently experiencing performance issues due to a problem with Microsoft Azure. This may result in slower loading times, pages failing to load, or pages being displayed incorrectly.
Posted Oct 29, 2025 - 17:14 CET
This incident affected: Nmbrs Netherlands (Web Application (APM), Sandbox, API), Nmbrs Sweden (Web Application (APM), Sandbox, API), and Mobile Application.