Slowness and errors in application

Incident Report for Nmbrs

Resolved

We've checked and received a lot of positive feedback and can now mark this incident as resolved.
Posted May 21, 2024 - 11:19 CEST

Monitoring

There should be a noticeable improvement after identifying and fixing the issue.
We keep on monitoring the issue.
Posted May 21, 2024 - 10:55 CEST

Update

Unfortunately we haven't found the cause and solution yet
Posted May 21, 2024 - 10:14 CEST

Investigating

At the moment you can experience slowness, issues with uploading documents and / or errors within the interactive payslip.
We are investigating the issue.
Posted May 21, 2024 - 09:40 CEST
This incident affected: Nmbrs Netherlands (Web Application (APM)).