Slowness in application and reports are unable to generate
Incident Report for Nmbrs
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 15:43 CET
Investigating
We are currently investigating this issue.
Posted Feb 01, 2021 - 11:05 CET
This incident affected: Visma Nmbrs Netherlands (Web Application (APM), Sandbox).