Mobile application currently experiencing degraded performance

Incident Report for Nmbrs

Resolved

Because the mobile application is working again, this incident is resolved. We will keep updating regarding the language issues via our 'known issues' on the support page.
Posted May 15, 2025 - 10:59 CEST

Update

The mobile application is working again but the language is still showing in English.
Posted May 15, 2025 - 10:06 CEST

Update

We are continuing to investigate this issue.
Posted May 15, 2025 - 03:40 CEST

Investigating

We are aware of an issue where opening the mobile application the app keeps loading. Our team is actively investigating this matter.
Posted May 15, 2025 - 03:27 CEST
This incident affected: Mobile Application.