Degraded performance on database server
Incident Report for Nmbrs
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 17, 2019 - 16:10 CET
Identified
The issue is identified. We're currently pushing improvements to the application.
Posted 4 months ago. Jan 17, 2019 - 16:00 CET
Investigating
We have received multiple mentions of slowness when working in the application. This situation is currently under investigation.
Posted 4 months ago. Jan 17, 2019 - 15:49 CET