It's currently not possible to create new ads for NMBRS Hire.
Incident Report for Nmbrs
Resolved
This incident has been resolved.
Posted Jul 03, 2023 - 09:56 CEST
Update
Issue has been solved.
Posted Jul 03, 2023 - 09:55 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 03, 2023 - 09:53 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 30, 2023 - 12:08 CEST
This incident affected: Nmbrs Hire (Nmbrs Hire).