Nmbrs NL offline
Incident Report for Nmbrs
Resolved
Nmbrs NL is back online.
Posted 4 months ago. Jan 26, 2019 - 23:29 CET
Update
We are continuing to investigate this issue.
Posted 4 months ago. Jan 26, 2019 - 23:21 CET
Investigating
Currently we are experiencing a major outage on all our servers. We are investigating this with the highest priority.
Posted 4 months ago. Jan 26, 2019 - 22:38 CET
This incident affected: Mobile Application.